Recently Found Problems (User Convertion)

Post any general problems, information or issues on ModphpBB3 in here.
Post Reply
User avatar
dannypritchett01
Forum Member
Forum Member
Posts: 54
Joined: Wed Dec 31, 2008 4:41 am

Recently Found Problems (User Convertion)

Post by dannypritchett01 » Sun Jan 18, 2009 1:31 am

Im not sure why but a few of my members were on the site playing around when they noticed some of my forums saying the topics dont exist. Also I was able to load an avatar however the others cant. I really hate to wipe the site and just start fresh but I may end up having too.

When we try to upload avatars we get the message "The upload was rejected because the uploaded file was identified as a possible attack vector."

User avatar
LDM
Site Admin
Site Admin
Posts: 1794
Joined: Thu May 29, 2008 6:51 pm

Re: Recently Found Problems

Post by LDM » Sun Jan 18, 2009 2:02 am

It's not ModphpBB3, it would be the conversion that you done in with the old forum.

I have heard of the avatar problem on a default phpBB after upgrading phpBB version but think that was back on phpBB 3.0.2.

Did you back up the old forum before convertion?

User avatar
dannypritchett01
Forum Member
Forum Member
Posts: 54
Joined: Wed Dec 31, 2008 4:41 am

Re: Recently Found Problems

Post by dannypritchett01 » Sun Jan 18, 2009 4:25 pm

Yes I backed up the old forum.
I really would like to get it fixed I have alreay had a lot of people winning on the arcade and have had a lot of posts made since then. Seems like users arent able to upload avatars or photos to their gallerys. One of my friends has an account there on the site and gave me his pass to get in and see if I could do it and I couldn't even make it work. Kept saying the person uploaded all the photos they were allowed and its set to unlimited and he has not uploaded a single one.

User avatar
LDM
Site Admin
Site Admin
Posts: 1794
Joined: Thu May 29, 2008 6:51 pm

Re: Recently Found Problems (User Convertion)

Post by LDM » Sun Jan 18, 2009 5:26 pm

First and foremost, lets just make the point this is not a fresh install and a user convertion. I need to clear that in case people reading the thread think that installation will give errors.

The best way to go about it, is install your old files and drop the tables that contain the modifications.

Then download [url=http://www,modphpbb3.com/ModphpBB3_1_0_4_Beta.zip]this older 1.0.4 version[/url] and follow Sewell's details in the thread of converting to 1.0.4. After that is done, update your phpBB version.

Then you are good to go with your old posts and members too.

My only thought is if you are getting errors from older conversion it may still confuse the database and your probably best to back-up to default as before then update via details above.

User avatar
dannypritchett01
Forum Member
Forum Member
Posts: 54
Joined: Wed Dec 31, 2008 4:41 am

Re: Recently Found Problems (User Convertion)

Post by dannypritchett01 » Sun Jan 18, 2009 9:33 pm

After all the work I put into the upgrade im about to wipe it out and start fresh.

User avatar
LDM
Site Admin
Site Admin
Posts: 1794
Joined: Thu May 29, 2008 6:51 pm

Re: Recently Found Problems (User Convertion)

Post by LDM » Sun Jan 18, 2009 9:47 pm

Not a fresh install? Just take out the modification tables in db (quite easy to find) and just overwrite the files with phpBB. That will take you back to 3.0.4 still with members and posts, then follow the manual in the other thread to convert it the easier way.

I'm sure 1.0.5 instructions will come soon if you are waiting for them.

User avatar
dannypritchett01
Forum Member
Forum Member
Posts: 54
Joined: Wed Dec 31, 2008 4:41 am

Re: Recently Found Problems (User Convertion)

Post by dannypritchett01 » Mon Jan 19, 2009 7:41 pm

How could I do this?

I need to insert the values needed for this query below... Keep in mind this is for my users to register for my custom phpbb site not the default of modphpbb3 for anyone viewing...

This is the file that installs my users after registering directly into phpbb for me.

Code: Select all

$user_row = array(
					'username'				=> $_POST['username'],
					'user_password'			=> phpbb_hash($_POST['password']),
					'user_email'			=> $_POST['email'],
					'group_id'				=> 2,
					'user_timezone'			=> 0,
					'user_dst'				=> 0,
					'user_lang'				=> 'en',
					'user_type'				=> 0,
					'user_actkey'			=> "",
					'user_ip'				=>  $_SERVER['REMOTE_ADDR'],
					'user_regdate'			=> time(),
					'user_inactive_reason'	=> 0,
					'user_inactive_time'	=> 0,
					'user_form_salt'		=> unique_id(),
					'user_options'		=> 895,
					'user_email_hash'	=>crc32(strtolower($user_row['user_email'])) . strlen($user_row['user_email']),
					'user_dateformat'=>'D M d, Y g:i a',
					'user_style'=>'1',
					'user_full_folder'		=> PRIVMSGS_NO_BOX,
					'user_notify'			=> 0,
					'user_notify_pm'		=> 1,
					'user_notify_type'		=> NOTIFY_EMAIL,
					'user_allow_pm'			=> 1,
					'user_allow_viewonline'	=> 1,
					'user_allow_viewemail'	=> 1,
					'user_allow_massemail'	=> 1,
					);
I need to insert the values...

Code: Select all

'user_avatar'	=> '',
					'user_arcade_pm'	=> 1,
					'games_per_page'	=> 0,
					'games_sort_dir'	=> a,
					'games_sort_order'	=> n,
					'user_gender'	=> 0,
					'user_arcade_permissions'	=> "",
					'user_arcade_perm_from'		=> 0,  
					'user_reminder_inactive'	=> 0,  
					'user_reminder_zero_poster'	=> 0,
					'user_reminder_inactive_still'	=> 0,
					'user_reminder_not_logged_in'	=> 0,
					'user_flag'		=> '',
However everything works fine and it even tries to register then it gives me a sql error stating...

Code: Select all

Field 'user_arcade_permissions' doesn't have a default valueinsert into phpbb_users
So the question is... What do I put in the ?? below to make it insert the values for this...

Code: Select all

`user_arcade_permissions` mediumtext collate utf8_bin NOT NULL,

Code: Select all

'user_arcade_permissions'	=> ??,

User avatar
LDM
Site Admin
Site Admin
Posts: 1794
Joined: Thu May 29, 2008 6:51 pm

Re: Recently Found Problems (User Convertion)

Post by LDM » Tue Jan 20, 2009 12:09 am

I'm guessing..

Code: Select all

'user_arcade_permissions'   => '0',
but it may help to ask the arcade author at http://www.jeffrusso.net

User avatar
dannypritchett01
Forum Member
Forum Member
Posts: 54
Joined: Wed Dec 31, 2008 4:41 am

Re: Recently Found Problems (User Convertion)

Post by dannypritchett01 » Wed Jan 21, 2009 3:03 pm

There was a step i was missing. Figured it out on my own lol.

User avatar
LDM
Site Admin
Site Admin
Posts: 1794
Joined: Thu May 29, 2008 6:51 pm

Re: Recently Found Problems (User Convertion)

Post by LDM » Wed Jan 21, 2009 3:08 pm

Danny did you change the user ID numbers when you converted, if not, it could explain why some posts were dodgy.

Post Reply