Chinese language

General topics relating to phpBB3 to be posted in here.
Post Reply
ottawasam
Forum Member
Forum Member
Posts: 2
Joined: Fri Jan 08, 2010 8:58 pm

Chinese language

Post by ottawasam » Fri Jan 08, 2010 9:06 pm

I installed phpBB3 from cpanel of my website and chose simlyfied version of Chinese. When I tried to change forum from first forum to Chinese characters, I see folloing errors, please help.
SQL ERROR [ mysql4 ]

Incorrect string value: '\xE4\xB8\xAD\xE6\x96\x87...' for column 'forum_name' at row 1 [1366]

SQL

UPDATE phpbb_forums SET parent_id = 1, forum_type = 1, forum_status = 0, forum_parents = '', forum_name = '中文帮助', forum_link = '', forum_desc = 'Description of your first forum.', forum_desc_uid = '', forum_desc_options = 7, forum_desc_bitfield = '', forum_rules = '', forum_rules_uid = '', forum_rules_options = 7, forum_rules_bitfield = '', forum_rules_link = '', forum_image = '', forum_style = 0, display_subforum_list = 1, display_on_index = 1, forum_topics_per_page = 0, enable_indexing = 1, enable_icons = 1, enable_prune = 0, prune_days = 0, prune_viewed = 0, prune_freq = 0, forum_flags = 32 WHERE forum_id = 2

BACKTRACE


FILE: includes/db/mysql.php
LINE: 174
CALL: dbal->sql_error()

FILE: includes/acp/acp_forums.php
LINE: 1242
CALL: dbal_mysql->sql_query()

FILE: includes/acp/acp_forums.php
LINE: 179
CALL: acp_forums->update_forum_data()

FILE: includes/functions_module.php
LINE: 507
CALL: acp_forums->main()

FILE: adm/index.php
LINE: 74
CALL: p_master->load_active()

User avatar
cisco007
Staff
Staff
Posts: 501
Joined: Tue Oct 07, 2008 3:44 am

Re: Chinese language

Post by cisco007 » Sun Jan 10, 2010 4:33 am

when you say from cpanel do you mean, you used intallatron or one of those autoinstaller programs!?

ottawasam
Forum Member
Forum Member
Posts: 2
Joined: Fri Jan 08, 2010 8:58 pm

Re: Chinese language

Post by ottawasam » Fri Jan 15, 2010 11:50 pm

Yes, I used one of the automatic tool to instal the forum, but I did choose chinese simplified language.

User avatar
cisco007
Staff
Staff
Posts: 501
Joined: Tue Oct 07, 2008 3:44 am

Re: Chinese language

Post by cisco007 » Sat Jan 16, 2010 12:51 am

why don't you try to download the package from phpbb.com along with your language, and install it yourself. Those automatic tools have been known to cause issues!

Post Reply